На основании чего формируется

Содержание

Ввод на основании

На основании чего формируется

Ввод на основании используется в случаях, когда при создании нового объекта могут быть использованы данные уже существующего объекта.

Ввод на основании может быть реализован для справочников, документов, планов видов характеристик, планов счетов, планов видов расчета и бизнес-процессов.

В общем случае объект может быть создан на основании любого объекта из перечисленных выше, например, документ может быть создан на основании справочника.

Рассмотрим работу механизма ввода на основании на следующем примере: Организация оказывает услуги пассажирского такси. Заказы покупателей регистрируются в документе «Заказ». Заказ может быть формируется диспетчером. Документ «Заказ» содержит следующую информацию:

  1. имя клиента
  2. адрес клиента
  3. адрес откуда
  4. адрес куда
  5. время подачи
  6. желаемый класс автомобиля
  7. список желаемых опций

Имя клиента, его адрес и телефон хранятся в справочнике «Клиенты». В данном примере будет реализован ввод документа на основании справочника. С целью упрощения примера справочник будет только один – «Клиенты», вся остальная информация будет вводиться вручную.

Создание объектов конфигурации

Справочник “Клиенты”:

Документ «Заказ»:

Реализация

В свойствах документа «Заказ» перейдем на закладку «Ввод на основании»:

Нажмем кнопку «Редактировать элемент списка» и выберем из списка справочник «Клиенты»:

Далее запустим конструктор ввода на основании нажатием на кнопку “Конструктор ввода на основании”:

В открывшемся окне нужно сопоставить поля справочника с реквизитами документа заказа. Это можно сделать, нажав кнопку «Заполнить выражения» и тогда система попытается сама определить, какие поля необходимо скопировать:

Поле адреса нужно сопоставлять вручную, выбрав поле «АдресОткуда» в нижней части, а затем двойным щелчком на реквизите «Адрес» в реквизитах объекта обоснования:

По нажатию «ОК» система генерирует следующий код в модуле документа «Заказ» в процедуре ОбработкаЗаполнения:

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка) //{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ // Данный фрагмент построен конструктором. // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!! Если ТипЗнч(ДанныеЗаполнения) = Тип(“СправочникСсылка.Клиенты”) Тогда // Заполнение шапки АдресОткуда = ДанныеЗаполнения.Адрес; Клиент = ДанныеЗаполнения.Ссылка; Телефон = ДанныеЗаполнения.Телефон; КонецЕсли; //}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ КонецПроцедуры

Процедура ОбработкаЗаполнения вызывается в ряде случаев, таких как ввод нового документа интерактивно и ввод на основании.

В данном случае, если переменная ДанныеЗаполнения является ссылкой на справочник клиентов, выполняется заполнение реквизитов документа. Код обработчика можно модифицировать. Предположим, что клиенты чаще всего хотят подачу такси в течение 15-20 минут.

Тогда в код обработчика можно добавить инициализацию реквизита «ВремяПодачи». Также удалим комментарии, созданные конструктором:

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка) Если ТипЗнч(ДанныеЗаполнения) = Тип(“СправочникСсылка.Клиенты”) Тогда АдресОткуда = ДанныеЗаполнения.Адрес; Клиент = ДанныеЗаполнения.Ссылка; Телефон = ДанныеЗаполнения.Телефон; ВремяПодачи = ТекущаяДата() + 900; // 15 * 60 секунд КонецЕсли; КонецПроцедуры

 Запустим приложение в режиме отладки и проверим, как работает ввод на основании. Добавим пару записей в справочник клиентов:

Откроем одну из них. В окне будет доступна кнопка «Создать на основании», по нажатию которой откроется список с опцией выбора «Заказ»:

При выборе «Заказ» система создает пустой документ и заполняет поля в процедуре ОбработкаЗаполнения:

Сохраним документ и убедимся, что документ был успешно создан, открыв его из спиcка документов заказа:

Теперь предположим, что у клиентов могут быть опции, которые всегда присутствуют в заказе данного клиента. Например, «Некурящий водитель». Тогда их можно задавать в справочнике клиентов и копировать в документ заказа. Расширим справочник «Клиенты» табличной частью «Опции»:

Теперь необходимо модифицировать процедуру ОбработкаЗаполнения документа. Это можно было бы сделать через конструктор, но тогда процедура обработки будет перезаписана, поэтому добавим код копирования табличной части вручную:

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка) Если ТипЗнч(ДанныеЗаполнения) = Тип(“СправочникСсылка.Клиенты”) Тогда // Заполнение шапки АдресОткуда = ДанныеЗаполнения.Адрес; Клиент = ДанныеЗаполнения.Ссылка; Телефон = ДанныеЗаполнения.Телефон; ВремяПодачи = ТекущаяДата() + 900; // 15 * 60 секунд Для Каждого ТекСтрока Из ДанныеЗаполнения.Опции Цикл НоваяЗапись = Опции.Добавить(); НоваяЗапись.Опция = ТекСтрока.Опция; НоваяЗапись.Количество = ТекСтрока.Количество; КонецЦикла; КонецЕсли; КонецПроцедуры

 Запустим конфигурацию в режиме отладки и посмотрим, что получилось. Добавим опции клиенту:

Сохраним данные и создадим заказ на основании записи справочника:

Таким образом, данные табличной части были успешно скопированы в заказ. Для этого простого примера реализацию ввода на основании можно считать законченной.

Источник: https://infostart.ru/1c/articles/333200/

Все, что нужно знать про штатное расписание в 2020 году

На основании чего формируется

Штатное расписание — это план комплектования кадрового состава. Некоторые компании пренебрегают им, однако ГИТ может посчитать это нарушением.

На практике штатное расписание необходимо и помогает работодателю как для внутреннего контроля и управления, так и при общении с проверяющими органами. Сегодня разбираемся в аспектах подготовки и ведения документа: штатное расписание на 2020 год оформляем по всем правилам.

Стоит отметить, что при составлении всех внутренних документов компании важно правильно указывать название должностей, профессий и специальностей сотрудников. Как отмечено в части 2 ст.

57 ТК РФ, если труд в определенной должности связан с ограничениями или предполагает наличие льгот, наименование этой должности (специальности, профессии) должно строго соответствовать названию, содержащемуся в профессиональном стандарте или квалификационном справочнике.

Точность в наименовании должности очень важна для сотрудника при оформлении льготного пенсионного обеспечения.

Важнейшим условием предоставления пенсионных льгот является точное соответствие записей о названии должностей и профессий, указанных в трудовых книжках сотрудников и штатном расписании, Спискам № 1 и № 2 производств, работ, профессий, должностей и показателей, дающих права рассчитывать на льготное пенсионное обеспечение, которые утверждены постановлением Кабинета министров СССР от 26.01.1991 № 10.

Чем грозит отсутствие штатного расписания

Поскольку форма эта лишь рекомендательная, многие работодатели задаются вопросом, насколько она обязательна. Ответ прост. Этот внутренний документ организации обычно просят предоставить трудовые и налоговые инспекции при проверках.

Несмотря на то, что в ТК прямого указания на его обязательность нет, но есть упоминание в статьях 15, 57 и др. ТК РФ, и из этого ГИТ делает вывод об обязательности документа. Его отсутствие трактуется как нарушение законодательства о труде и охране труда.

За такое нарушение должностное лицо штрафуют на 1000-5000 рублей, организацию — на сумму от 30 000 до 50 000 рублей (ст. 5.27 КоАП РФ).

Этот документ помогает обосновать увольнение сотрудников по сокращению штата при рассмотрении дела в суде. Без этого документа работодателю сложно доказать, что увольнение оправданно.

Также невозможно доказать, что на момент увольнения в организации не было вакансий, которые необходимо было предложить сокращаемым работникам (работодатель обязан при сокращении предложить другие рабочие места по ст.

179 ТК РФ; для этого они должны быть указаны в штатке).

Кто и как составляет и ведет штатное расписание

Вообще говоря, составление документации такого рода — функция и святая обязанность экономиста по труду из отдела организации и оплаты труда (Квалификационный справочник должностей руководителей, специалистов и других служащих, постановление Минтруда России № 37 от 21.08.1998). Этому специалисту поможет в работе образец заполнения штатного расписания 2020: он наглядно показывает порядок ведения и заполнения документа.

Однако по факту учет кадрового состава ведут бухгалтеры, кадровики и юристы, которым приходится разбираться в том, как рассчитать количество ставок.

Так как штатное расписание представляет собой утвержденный высшим руководством нормативный документ организации, оформляющий структуру и численность работников с указанием размера зарплаты в зависимости от занимаемой должности, то официально отвечают за документ руководитель компании и главный бухгалтер, поскольку они его подписывают.

Немаловажен вопрос, когда утверждается штатное расписание на следующий год? Эту форму составляют на любой срок, но обычно ее делают на год и всякий раз пересматривают в начале года. Чтобы эта процедура всякий раз проходила, как по маслу, стоит описать ее в инструкции по делопроизводству и указать:

  • сроки и правила разработки и внесения изменений;
  • форму приказа об утверждении штатки;
  • ответственных за формирование и подписание лиц;
  • состав правовых и локальных нормативных актов работодателя, на основании которых создается документ;
  • работников, с которыми необходимо согласовывать проект документа и изменения в него.

Форма документа

Разобравшись с вопросом, что такое штатное расписание, перейдем к вопросу о его форме. Этот документ является локальным нормативным актом, описывающим организационную структуру компании и содержащим сведения о численности ее персонала.

Составляется оно по форме № Т-3 (постановление № 1 Госкомстата РФ “Об утверждении унифицированных форм первичной учетной документации по учету труда и его оплаты” от 05.01.2004), но жестких требований использовать ее нет — форма является рекомендательной. Каждая компания адаптирует ее под собственные нужды.

Мы рекомендуем использовать форму № Т-3 в ее обычном виде, поскольку она содержит все нужные данные. Вот так выглядит форма штатного расписания на 2020 год, утвержденная постановлением Госкомстата.

Как корректно заполнить форму № Т-3

Разберем пошагово пример штатного расписания ООО 2020 года. Реквизиты формы оформляем, как показано на примере.

Наименование организации должно полностью соответствовать тому, которое закреплено в учредительных документах, включая сокращенное наименование и наименование на иностранном языке. Если есть сокращенное наименование, оно в бланке указывается в скобках, следом за полным.

Код организации — восемь знаков кода по Общероссийскому классификатору предприятий и организаций (ОКПО).

Номер документа и дата составления записываются в формате ЧЧ.ММ.ГГГГ

Период действия. Указывается, сколько действителен документ и с какой даты он вступает в силу.

Заполняем графы, всего их 10.

Наименование структурного подразделения указывается без сокращения в соответствии с классификатором подразделений, утвержденным работодателем.

Если классификатора нет, то в алфавитном порядке или в порядке убывания числа сотрудников подразделения.

Если от наименования подразделения зависит предоставление работникам льгот, указываем название подразделения в соответствии с отраслевыми классификаторами вредных производств и другими соответствующими документами.

Код структурного подразделения в документе заполняем в соответствии с классификатором, в котором они расположены по функциональной важности. Если классификатора нет, коды допускается присвоить подразделениям, расположенным в алфавитном порядке или по иному принципу.

Должность (специальность, профессия), разряд, класс (категория), квалификация в штатном указывается без сокращений в составе структурного подразделения, начиная от руководителя, заканчивая техническим исполнителем. Внимание: у рабочих — профессии, у служащих — должности (абз. 7 ст. 144 ТК РФ).

Количество единиц указывается по каждой должности или профессии. Если предусматривается работа по совместительству, указывается в соответствующих долях (например 0,5; 2,75 и т. д.).

Тарифная ставка, оклад указываются в размере месячной заработной платы в зависимости от системы оплаты труда (тариф, оклад, процент от прибыли, коэффициент трудового участия и проч.).

Размер оклада необходимо указывать в рублях или в процентах, коэффициентах и проч. Практика указывать зарплаты в долларах практически изжила себя.

Закон о валютном регулировании прямо это запрещает, а в ТК РФ говорится об обязанности работодателя платить зарплату в рублях.

Надбавки. В графах 6-8 указываются стимулирующие и компенсационные выплаты, установленные законом или по инициативе работодателя.

В разделе «Всего» указывается общая сумма граф 5-8 (оклад и надбавки), умноженная на количество штатных единиц.

Примечание заполняется, если информация в графах формы неоднозначна и требует пояснения.

В строке «Итого» указывают общее количество штатных единиц и итогом сумму выплат по всем ставкам с учетом всех надбавок, которая составит месячный фонд заработной платы.

Подписи под проектом приказа ставят кадровый руководитель и главный бухгалтер.

Не забудьте проставить номер документа в соответствующей графе формы.

Готовим приказ на утверждение

Проект документа готов, что дальше? Чтобы ввести штатное, его утверждают соответствующим приказом по основной деятельности. Приказ на штатное расписание на 2020 года упоминается в верхнем правом углу бланка следующим образом.

В тексте приказа указывается факт утверждения штатного расписания, общее количество штатных единиц и срок введения документа в действие. Приказ подписывается руководителем компании или другим уполномоченным лицом, а затем регистрируется в журнале регистрации приказов по основной деятельности.

Регистрационный номер проставляется на приказе. Затем приказ и расписание отправляются на хранение, как правило, вместе с другими документами по основной деятельности (расписание — на постоянное хранение, а приказ — на 75 лет, см. пункт 19 и 71 перечня, утвержденного приказом Минкультуры России от 25.08.

2010 № 558).

Как вносить изменения

Поскольку штатное расписание утверждается приказом, то и изменения в него вносятся соответствующими приказами. Дата выпуска приказа об изменении и дата вступления изменений в силу обычно не совпадают.

Изменения обычно затрагивают штатных сотрудников, поэтому за ним следует изменение трудовых договоров. В большинстве случаев для их применения требуется согласие работников, соблюдение сроков уведомления персонала и прочее.

Ознакомление работника с приказом о внесении изменения в штатное расписание не является подтверждением его согласия на изменение условий трудового договора.

Посмотрим, как отразить изменение оклада сотрудников. Работодатель обязан за два месяца уведомить об этом персонал, а затем издает приказ о внесении изменений в штатное расписание. В приказе указываются должности, новые оклады и время вступления изменений в силу. Сотрудники отдела кадров, которые будут вносить изменения в трудовые договоры, знакомятся с приказом под подпись.

Затем с работниками заключают дополнительные соглашения. В них недостаточно ограничиться фактом увеличения или уменьшения оклада, необходимо указать причины (по ст. 22 и 132 ТК РФ.

Зарплата работника — это существенное условие трудового договора, ее размер зависит от квалификации, сложности выполняемой работы, количества и качества затраченного труда).

В противном случае сотрудник, например, сможет потребовать доплатить ему за предыдущие периоды, в которые он делал то же самое, но за меньшие деньги.

Уменьшать размер оплаты труда в одностороннем порядке по ст.

74 ТК РФ можно, но это требует точного соблюдения всей процедуры: издания необходимого приказа о введении изменений, письменного уведомления работников за два месяца, и обязательного предложения всех штатных вакантных должностей работнику, отказывающемуся трудиться в новых условиях.

Если сотрудник согласен на новые условия, с ним заключается дополнительное соглашение. Если он готов занять иную вакантную штатную должность, оформляется перевод. Если, несмотря на соблюдение всей процедуры, работник отказывается трудиться за меньшую заработную плату, работодатель вправе уволить его по п. 7 ч. 1 ст. 77 ТК РФ.

Источник: https://ppt.ru/news/126751

Положение как организационно-правовой документ

На основании чего формируется

Фундаментом организационной деятельности любого учреждения являются организационно-правовые документы. Они регламентируют статус организации, ее структуру, штатную численность, должностной состав, а также определяют права, обязанности, ответственность и порядок взаимодействия ее обособленных, структурных подразделений и должностных лиц.

В данной статье мы подробно остановимся на таком организационно-правовом документе, как положение.

Наша справка

К организационно-правовым документам относятся:

  • устав;
  • учредительный договор;
  • положение об организации;
  • положения о структурных, обособленных подразделениях, о коллегиальном (совещательном) органе организации и т.д.;
  • регламент;
  • штатное расписание;
  • инструкция;
  • должностная инструкция;
  • правила внутреннего трудового распорядка и др.

Все организационно-правовые документы подлежат утверждению либо вышестоящей организацией, либо руководителем или коллегиальным органом (если он есть) – советом директоров, собранием акционеров и т.п. Все нормы, содержащиеся в этих документах, обязательны для исполнения.

Виды положений

Наш словарик

Положение – это организационно-правовой документ, регламентирующий порядок образования, права, обязанности, ответственность и организацию работы структурного подразделения (должностного лица, совещательного или коллегиального органа), а также его взаимодействие с другими подразделениями и должностными лицами.

В коммерческой организации могут действовать несколько видов положений:

  • Положение об организации;
  • положения о структурных подразделениях, например Положение о бухгалтерии или Положение об отделе кадров;
  • положения, определяющие деятельность комиссии или группы, например Положение об экспертной архивной комиссии;
  • положения, регламентирующие работу должностных лиц, например Положение о генеральном директоре;
  • положения, регулирующие организационные отношения по какому-либо конкретному вопросу, например Положение об аттестации работников или положение о работе с заявлениями и претензиями физических лиц.

Практическая польза положений состоит в том, что в них максимально конкретно прописано, кто и что должен делать, какие задачи выполнять и за что нести ответственность. В свою очередь, это значительно облегчает контроль за выполнением поручений руководителя.

Когда два отдела организации «перебрасывают» друг на друга выполнение какой-либо задачи, затягивая ее решение, и не могут договориться между собой, кто и что будет делать, помогут разобраться положения о подразделениях.

Поэтому дальновидные руководители обычно лично заинтересованы в том, чтобы было подготовлено положение об их отделе и чтобы оно было настолько подробным, насколько это возможно.

Самый простой пример: отдел хочет сдать в архив неоформленные документы – в скоросшивателях или вовсе россыпью. Документы не отсортированы и неизвестно, к каким делам они относятся.

Начальник отдела настаивает на том, что разбирать эти документы и формировать их в дела должен секретарь.

Секретарь же, открыв Положение об архиве, обращает внимание начальника на то, что в архив принимаются документы, сформированные в дела в соответствии с номенклатурой дел. Это внутрикорпоративный закон, и с ним приходится считаться.

Обратите внимание

Такие документы, как Положение об аттестации, Положение о работе с претензиями и др., по сути являются  пошаговыми руководствами к действию: в них подробно описан каждый этап решения той или иной задачи.

Положение о структурном подразделении

Положения о структурных подразделениях, пожалуй, самая распространенная и востребованная разновидность положений.

Поскольку требования к положениям о структурных подразделениях и правила их разработки законодательно не установлены, каждая организация самостоятельно решает, какие вопросы деятельности конкретного подразделения должны быть урегулированы в этих локальных нормативных актах. Основные разделы стандартного Положения о подразделении представлены в таблице.

Основные разделы Положения о подразделении и их содержание

Раздел положения раздела
1Общие положения
  • полное наименование структурного подразделения (далее – СП);
  • наименование, номер, дата правового акта, на основании которого создано СП;
  • нормативные документы, которыми СП руководствуется в своей деятельности;
  • кто возглавляет СП;
  • кому подчиняется СП;
  • порядок назначения и освобождения от должности руководителя СП;
  • наличие печати
2Основные задачиЗадачи, для решения которых создано и работает СП
3ФункцииКонкретные виды работ, выполняемые СП в рамках решения своих основных задач
4Права и обязанностиПрава и обязанности руководителя и работников  СП при выполнении своих функций
5ОтветственностьВиды ответственности, которую может понести руководитель и работники СП в случае невыполнения своих обязанностей (дисциплинарная, административная, а в некоторых случаях и уголовная)
6ВзаимоотношенияПорядок взаимодействия СП с другими подразделениями организации: в какой форме осуществляется, какие документы при этом создаются и т.д.

Реквизиты положения

При подготовке положения оформляются  следующие реквизиты документа:

  • наименование организации;
  • наименование вида документа;
  • заголовок к тексту;
  • дата документа;
  • регистрационный номер документа;
  • место составления или издания документа;
  • гриф утверждения документа;
  • текст документа;
  • визы согласования документа.

Рассмотрим подробнее особенности оформления этих реквизитов в положениях.

  • Наименование организации. Название организации-автора указывается согласно учредительным документам. Если в этих документах наряду с полным имеется и сокращенное наименование, то оно также указывается (Пример 1). Наименования на языках субъектов Российской Федерации или на иностранных языках указываются ниже наименования на русском или справа от него на одном уровне.

Автором положения может быть как филиал, так и структурное подразделение – в этом случае его название указывается под наименованием организации (см. Пример 1).

Авторами положения могут быть две и более организации (например, если создается Положения о взаимоотношениях). В этом случае наименования организаций располагаются на одном уровне (если речь идет о компаниях, не подчиненных друг другу), как в Примере 2, и на разных уровнях (если одно учреждение подчинено другому).

  • Наименование вида документа. Данный реквизит печатается прописными буквами: ПОЛОЖЕНИЕ, точка после него не ставится.
  • Заголовок к тексту. Набирается с новой строки и отвечает на вопросы: о чем (о ком)? (см. варианты расположения реквизита в Примерах 1 и 2).
  • Дата документа. Датой документа является дата его утверждения. Она проставляется в соответствующем поле утверждающим должностным лицом. Если положение подписывается двумя и более организациями, то его датой будет дата последнего утверждения (см. Пример 2).
  • Регистрационный номер документа. Даже если данное положение первое и единственное в своем роде, то номер ему все равно нужно присвоить: государственный стандарт[1] требует нумерации абсолютно каждого документа, созданного в организации. Положение, созданное двумя организациями, получает два номера, которые пишутся через дробь (см. Пример 2).
  • Место составления или издания документа. Этот реквизит оформляется в том случае, если место издания положения нельзя определить по наименованию организации. Так, например, для ЗАО «Томские коммунальные системы» заполнять его не требуется, в отличие от ОАО «Средневолжская строительная компания». Если в первом случае ясно, где находится предприятие, то по второму наименованию точное местонахождение организации определить невозможно.

С другой стороны, если документ издается филиалом ЗАО «Томские коммунальные системы», расположенном в районном центре Томской области, то именно этот районный центр и будет указан в качестве места составления документа (см. Пример 1).

  • Гриф утверждения документа. Обычно положения утверждаются руководителем организации. Но в рамках своей компетенции и при наличии соответствующих полномочий это может сделать и другое должностное лицо. Например, Положение о делопроизводстве по обращениям граждан может утвердить и административный директор. Гриф утверждения в положении состоит из слова УТВЕРЖДАЮ, наименования должности лица, утверждающего документ, его подписи, инициалов, фамилии и даты утверждения (см. Пример 1).

Кроме того, положение может быть утверждено распорядительным документом – обычно приказом по основной деятельности. В этом случае гриф утверждения состоит из слова УТВЕРЖДЕНО, наименования утверждающего документа (в творительном падеже), его даты и номера (см. Пример 2).

Пример 1

Верхняя часть положения, изданного филиалом организации

Общество с ограниченной ответственностью «Самарское строительное предприятие» (ООО «ССП»)Тольяттинский филиалПОЛОЖЕНИЕ о работе с заказчиками – физическими лицами«10» июня 2014 г. № 12-ОПДг. ТольяттиУТВЕРЖДАЮ Начальник филиалаРомашов Л.А. Ромашов 10.06.2014

Пример 2

Верхняя часть положения, утвержденного двумя организациями

Закрытое акционерное общество «Авторемонтное предприятие»Общество с ограниченной ответственностью «Восточный логистический центр» (ООО «ВЛЦ»)

Источник: https://www.profiz.ru/sr/8_2014/polozhenie/

Постановление Правительства Российской Федерации от 29 декабря 2008 г. N 1065 г. Москва

На основании чего формируется

В соответствии с пунктами 3 и 4 статьи 692 Бюджетного кодекса Российской Федерации Правительство Российской Федерации постановляет:

1.

Утвердить прилагаемое Положение о формировании и финансовом обеспечении выполнения государственного задания федеральными органами исполнительной власти и федеральными государственными учреждениями.

2. Министерству финансов Российской Федерации по согласованию с Министерством экономического развития Российской Федерации до 1 марта 2009 г.

утвердить методические рекомендации по определению расчетно-нормативных затрат на оказание федеральными органами исполнительной власти и (или) находящимися в их ведении федеральными государственными бюджетными учреждениями государственных услуг физическим и юридическим лицам, а также расчетно-нормативных затрат на содержание имущества федеральных государственных бюджетных учреждений.

3. Настоящее постановление вступает в силу с 1 января 2009 г.

Председатель Правительства Российской Федерации
В. Путин

Положение о формировании и финансовом обеспечении выполнения государственного задания федеральными органами исполнительной власти и федеральными государственными учреждениями

1.

Настоящее Положение устанавливает порядок формирования и финансового обеспечения выполнения федеральными органами исполнительной власти и федеральными государственными учреждениями государственного задания на оказание ими государственных услуг физическим и юридическим лицам за счет бюджетных ассигнований федерального бюджета (далее соответственно – государственное задание, государственная услуга).

2. Государственное задание формируется по форме согласно приложению N 1 и устанавливает требования к составу, качеству и (или) объему, условиям, порядку и результатам оказания одной государственной услуги.

Государственное задание может содержать требования к оказанию нескольких государственных услуг. В этом случае государственное задание может включать несколько разделов, каждый из которых должен содержать требования к оказанию одной государственной услуги.

3. Государственное задание формируется в срок не позднее 1 месяца после официального опубликования федерального закона о федеральном бюджете на очередной финансовый год и на плановый период.

4. Государственное задание формируется на основе перечня государственных услуг, утверждаемого федеральным органом исполнительной власти, осуществляющим функции по выработке государственной политики и нормативно-правовому регулированию в установленной сфере деятельности ежегодно, до 1 мая, по форме согласно приложению N 2.

В перечень государственных услуг, оказываемых федеральным органом исполнительной власти, включаются государственные услуги, в отношении которых утверждены административные регламенты исполнения государственных функций (предоставления государственных услуг).

Утвержденный перечень государственных услуг размещается на официальном сайте соответствующего федерального органа исполнительной власти в сети Интернет.

5. Государственное задание формируется:

а) для федеральных органов исполнительной власти, руководство деятельностью которых осуществляет Президент Российской Федерации или Правительство Российской Федерации, – федеральными органами исполнительной власти в соответствии с решением (поручением) Президента Российской Федерации или Правительства Российской Федерации;

б) для федеральных служб и федеральных агентств – федеральными министерствами, в ведении которых находятся эти службы и агентства;

в) для федеральных государственных бюджетных учреждений – главными распорядителями средств федерального бюджета, в ведении которых они находятся;

г) для федеральных государственных автономных учреждений, созданных на базе имущества, находящегося в федеральной собственности, – главными распорядителями средств федерального бюджета, осуществляющими функции и полномочия учредителей с учетом Положения о формировании задания учредителя в отношении автономного учреждения, созданного на базе имущества, находящегося в федеральной собственности, и порядке финансового обеспечения выполнения задания, утвержденного постановлением Правительства Российской Федерации от 18 марта 2008 г. N 182.

6.

В случае внесения изменений в нормативные правовые акты, на основании которых было сформировано государственное задание, а также изменения размера выделяемых бюджетных ассигнований федерального бюджета, которые являются источником финансового обеспечения государственного задания, в государственное задание могут быть внесены изменения в порядке, предусмотренном пунктом 5 настоящего Положения.

7. Финансовое обеспечение выполнения государственного задания осуществляется в пределах бюджетных ассигнований, предусмотренных сводной бюджетной росписью федерального бюджета и (или) бюджетными росписями главных распорядителей средств федерального бюджета.

8. Финансовое обеспечение выполнения государственного задания федеральным органом исполнительной власти осуществляется главным распорядителем средств федерального бюджета с учетом расчетно-нормативных затрат на оказание соответствующих государственных услуг при определении показателей бюджетной сметы этого федерального органа исполнительной власти.

Порядок определения указанных затрат утверждается федеральным органом исполнительной власти по согласованию с Министерством финансов Российской Федерации и Министерством экономического развития Российской Федерации ежегодно, до 1 мая.

9.

Финансовое обеспечение выполнения государственного задания федеральным государственным бюджетным учреждением осуществляется главным распорядителем средств федерального бюджета с учетом расчетно-нормативных затрат на оказание соответствующих государственных услуг и расчетно-нормативных затрат на содержание имущества федерального государственного бюджетного учреждения при определении показателей его бюджетной сметы.

Порядок определения указанных затрат утверждается главным распорядителем средств федерального бюджета по согласованию с Министерством финансов Российской Федерации и Министерством экономического развития Российской Федерации ежегодно, до 1 мая.

10.

Финансовое обеспечение выполнения государственного задания федеральным государственным автономным учреждением осуществляется в соответствии с Положением о формировании задания учредителя в отношении автономного учреждения, созданного на базе имущества, находящегося в федеральной собственности, и порядке финансового обеспечения выполнения задания, утвержденным постановлением Правительства Российской Федерации от 18 марта 2008 г. N 182.

11. Утвержденный главным распорядителем средств федерального бюджета порядок определения расчетно-нормативных затрат на оказание государственной услуги для федеральных государственных бюджетных учреждений не может отличаться от порядка, установленного для определения нормативов затрат на оказание аналогичной государственной услуги федеральными государственными автономными учреждениями.

12. Контроль за соблюдением федеральными службами и федеральными агентствами требований и условий, установленных для них государственными заданиями, осуществляют федеральные министерства, в ведении которых они находятся.

Контроль за соблюдением федеральными государственными учреждениями требований и условий, установленных для них государственными заданиями, осуществляют главные распорядители средств федерального бюджета, в ведении которых они находятся.

13. Государственные задания и отчеты об исполнении государственных заданий размещаются на официальном сайте соответствующего федерального органа исполнительной власти (главного распорядителя средств федерального бюджета) в сети Интернет.

Источник: https://rg.ru/2009/01/21/goszadanie-dok.html

Ввод на основании в 1С программно

На основании чего формируется

Рассмотрим простой пример программного ввода документа в 1С на основании. Допустим необходимо после проведения приходного документа «Приход» создать расходный документ «Расход» на основании данных полученных из приходного документа.

Простое создание на основании стандартным способом платформы 1С

В документе «Расход» или «Приход» нужно настроить связь на вкладке «Ввод на основании»:

Где указать с кем он связан:

Должна получиться следующая картина:

Если вы только начинаете программировать в 1С или просто хотите систематизировать свои знания – попробуйте Школу программирования 1С нашего друга Владимира Милькина. Пошаговые и понятные уроки даже для новичка с поддержкой учителя.
Попробуйте бесплатно по ссылке >>

Далее в модуле документа «Расход» нужно создать процедуру «Обработка заполнения» с помощью клика в верхнем меню:

Если в документе уже существуют данная процедура — нужно не создавать новую, а добавлять код в существующую процедуру.

И прописать программный код заполнения. Пример кода:

//Код из модуля объекта документа “Расход”. Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)                       Если ТипЗнч(ДанныеЗаполнения) = Тип(“ДокументСсылка.Приход”) Тогда                                               Склад = ДанныеЗаполнения.Склад;                         Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл                                    НоваяСтрока = Товары.Добавить();                                    НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;                                    //… заполняем другие реквизиты табличной части                         КонецЦикла;                                   КонецЕсли; КонецПроцедуры

Программный код можно также создать автоматически для этого нужно воспользоваться «Конструктором ввода на основания».

Конструктор ввода на основании

Чтобы в 1С автоматически создать процедуру, нужно нажать на кнопку «Конструктор ввода на основании»:

Где с помощью функции «Заполнить выражения» можно автоматически сопоставить название реквизитов:

Если реквизиты различаются по названию, их можно сопоставить вручную. Например, в одной табличной части у вас реквизит «Номенклатура», а в другой «Товар».

После нажатия на «Ок», 1С сама сформирует готовый программный код:

Внимание! Конструктор нельзя использовать, если процедура заполнения уже существует — вы потеряете существующий программный код.

Создание документа после записи первого документа с последующей записью созданного

Для реализации такой задачи можно использовать метод объекта Заполнить(), в параметры которого необходимо будет передать данные заполнения из документа прихода.  Метод инициирует событие ОбработкаЗаполнения() и вызов процедуры-обработчика в модуле объекта документа «Расход».

Пример кода:

//Код из модуля формы документа “Приход”. &НаСервере Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)                   //Создаём новый документ             НовДокумент = Документы.Расход.СоздатьДокумент();             //Заполняем созданный документ (реквизиты документа заполняются значениями, которые совпадают по именам реквизитов)             НовДокумент.Заполнить(ТекущийОбъект.Ссылка);             //Записываем созданный документ             НовДокумент.Записать(РежимЗаписиДокумента.Проведение,РежимПроведенияДокумента.Оперативный);           КонецПроцедуры //Код из модуля объекта документа “Расход”. Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)                       Если ТипЗнч(ДанныеЗаполнения) = Тип(“ДокументСсылка.Приход”) Тогда                                               Склад = ДанныеЗаполнения.Склад;                         Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл                                    НоваяСтрока = Товары.Добавить();                                    НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;                                    //… заполняем другие реквизиты табличной части                         КонецЦикла;                                   КонецЕсли; КонецПроцедуры

Создание объекта  после записи с открытием управляемой формы

Для программного создания документа в 1С с открытием управляемой формы пользователю можно использовать функцию ОткрытьФорму(), в параметры которой можно передавать данные для заполнения.

Пример кода:

//Код из модуля формы документа “Приход”. &НаКлиенте Процедура ПослеЗаписи(ПараметрыЗаписи) //Создаём структуру для передачи в виде параметра при открытии формы. ПараметрыФормы = Новый Структура(“Основание”, Объект.Ссылка); //Открываем форму документа расход с передачей данных для заполнения ОткрытьФорму(“Документ.Расход.ФормаОбъекта”, ПараметрыФормы); КонецПроцедуры //Код из модуля объекта документа “Расход”. Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка) Если ТипЗнч(ДанныеЗаполнения) = Тип(“ДокументСсылка.Приход”) Тогда Склад = ДанныеЗаполнения.Склад; Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл НоваяСтрока = Товары.Добавить(); НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура; // … заполняем другие реквизиты табличной части КонецЦикла; КонецЕсли; КонецПроцедуры

К сожалению, мы физически не можем проконсультировать бесплатно всех желающих, но наша команда будет рада оказать услуги по внедрению и обслуживанию 1С. Более подробно о наших услугах можно узнать на странице Услуги 1С или просто позвоните по телефону +7 (499) 350 29 00. Мы работаем в Москве и области.

Источник: https://programmist1s.ru/sozdat-na-osnovanii-programmno/

Поделиться:
Нет комментариев

    Добавить комментарий

    Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.